Installing Open vSwitch on Scientific Linux 7.3

To enable using Open vSwitch (OVS) on DTNs to control data transfer traffic (e.g., by shaping or steering) these instructions describe how to install OVS on SL7.3.

Most, if not all, of the commands require root permissions and these directions have been tested using the 'root' user ID.

These directions have also been tested from a remote host using Ansible with the playbook attached to this page.

The latest OVS version that seems compatible with SL7.3 is OVS 2.7.0 (at the time of this writing).

These directions are based primarily on https://github.com/openvswitch/ovs/blob/branch-2.7/Documentation/intro/install/fedora.rst

NOTE as of May 18 we have built and tested OVS 2.9.1 on SL7.4. The src and binary rpms are available at http://linat05.grid.umich.edu/OVS/rpms

This was the procedure followed on our ovs-sl7 build node:

mkdir -p ~/rpmbuild/{BUILD,RPMS,SOURCES,SPECS,SRPMS}

echo '%_topdir %(echo $HOME)/rpmbuild' > ~/.rpmmacros

git clone -b branch-2.9 https://github.com/openvswitch/ovs ovs

cd ovs

./boot.sh

./configure; make rpm-fedora RPMBUILD_OPT="--without check"

You should be able to use 2.9 wherever the older instructions refer to 2.7.

Preparation

Install (or verify installation of) the required packages.
 yum -y install git rpm-build autoconf automake libtool openssl openssl-devel python-twisted-core python-zope-interface desktop-file-utils groff graphviz procps-ng checkpolicy selinux-policy-devel libcap-ng libcap-ng-devel

Install the software collections package associated with the SL7 distribution.
 yum -y install http://ftp1.scientificlinux.org/linux/scientific/7x/external_products/softwarecollections/yum-conf-softwarecollections-2.0-1.el7.noarch.rpm

Clone the OVS repo into directory "ovs"
cd ~; git clone -b branch-2.7 https://github.com/openvswitch/ovs ovs

Build the OVS RPM

 cd ~/ovs; ./boot.sh; ./configure; make rpm-fedora RPMBUILD_OPT="--without check"

Install the OVS RPM

 yum -y install ~/ovs/rpm/rpmbuild/RPMS/x86_64/openvswitch-2.7.0-1.el7.x86_64.rpm

Start OVS

 systemctl start openvswitch

if desired, check that OVS is running
 ovs-vsctl show

This should show the version of OVS that is active (e.g., 'ovs version: "2.7.0"')

-- BenMackCrane - 06 Jun 2017
Topic attachments
I Attachment Action Size Date Who Comment
ovs-install-sl7.ymlyml ovs-install-sl7.yml manage 1.9 K 06 Jun 2017 - 15:57 BenMackCrane Ansible playbook for installing OVS 2.7.0 on SL7.3
Topic revision: r4 - 25 May 2018 - 12:06:43 - ShawnMcKee
 

This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback